UI Slowness
Incident Report for Bintray
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 24, 2017 - 03:30 UTC
Investigating
We are currently experiencing slowdowns in the UI due to irregular request patterns and are currently investigating this issue.
Posted 6 months ago. Mar 24, 2017 - 01:46 UTC