Degraded Download Performance
Incident Report for Bintray
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 16, 2015 - 12:11 UTC
Investigating
Bintray currently experiences download slowdowns, Investigation in progress
Posted almost 2 years ago. Nov 16, 2015 - 10:20 UTC