Search functionality is unavailable
Incident Report for Bintray
Resolved
Hell yeah, looks like we got it! It was long and painful, sorry everyone! Thanks for sticking with us!
Posted 3 months ago. Apr 06, 2018 - 08:35 UTC
Monitoring
Good news, everyone, looks like we're out of the woods! We enabled the search, everything looks good, and we're monitoring it closely.
Posted 3 months ago. Apr 04, 2018 - 14:57 UTC
Update
Unfortunately, we don't have any new updates just yet. We disconnected the search servers and working on making them stand the load. The downloads and the REST API (except the search) are functional.
Posted 3 months ago. Apr 03, 2018 - 22:02 UTC
Identified
We have to disable the search again. Here's the summary of what is currently unavailable:
1. Repo page for public repositories (package pages work and editing repository works)
2. Search REST API commands (everything goes to /search/)
3. The search box.
Posted 3 months ago. Apr 02, 2018 - 20:25 UTC
Monitoring
We enabled the search functionality and monitoring the behavior of our search clusters.
Posted 3 months ago. Apr 02, 2018 - 17:08 UTC
Update
We are performing significant maintenance work on the search services. They are still unavailable. Downloads, uploads, and the rest of the core functionality except searching and repository browsing in public repositories work. Here's the summary of what is currently unavailable:
1. Repo page for public repositories (package pages work and editing repository works)
2. Search REST API commands (everything goes to /search/)
3. The search box.

We will be back with more updates soon.
Posted 3 months ago. Apr 02, 2018 - 14:56 UTC
Update
Throwing more HW on the search machines didn't help. We keep looking.
Posted 3 months ago. Apr 01, 2018 - 13:43 UTC
Identified
Good news - all the downloads are working again.

Not so good news - we had to temporarily disable elasticsesearch, so search doesn't work on public repos, as well as public repositories browsing.

We're working on bringing the search and the browsing back up.
Posted 3 months ago. Mar 31, 2018 - 05:00 UTC
Investigating
Well, what we did didn't help. Back to square one, investigating. Thanks for your patience, everyone.
Posted 3 months ago. Mar 31, 2018 - 03:00 UTC
Monitoring
The search cluster is re-balanced again. Doing the last checks to verify everything is back to normal.
Posted 3 months ago. Mar 31, 2018 - 00:39 UTC
Identified
We’ve identified a bottleneck in оur search servers cluster and working to stabilizing it.
Posted 3 months ago. Mar 30, 2018 - 22:28 UTC
Update
We are still looking into the source of ElasticSearch chocking.
Posted 3 months ago. Mar 30, 2018 - 19:37 UTC
Investigating
Looks like downloads of certain file types (like npm, Docker, and Conan) are affected as well. Stay tuned for the updates as we working on it.
Posted 3 months ago. Mar 30, 2018 - 19:06 UTC
Identified
The issue is identified and we are working on the fix.
Posted 3 months ago. Mar 30, 2018 - 19:03 UTC
Investigating
We're investigating alerts on the slowness of the UI and the REST APIS on some cluster nodes. Downloads are fully functional.
Posted 3 months ago. Mar 30, 2018 - 17:57 UTC