Slowness with the Website, REST API and Downloads
Incident Report for Bintray
Postmortem

One of our larger customers performed a massive refactoring using a REST API which calls an underperforming query.

The query was optimized and a fix has been deployed.

Posted 3 months ago. Jul 27, 2018 - 15:16 UTC

Resolved
This incident has been resolved.
Posted 3 months ago. Jul 27, 2018 - 14:54 UTC
Monitoring
The incident was caused due to an increased load on Bintray's servers. This has been currently addressed and we keep on monitoring.
Posted 3 months ago. Jul 27, 2018 - 13:12 UTC
Update
Update:
The issue can be experienced as getting "bad gateway" errors and not just slowness. Updating the incident to "Partial Outage".
We are still investigating and will keep updating.
Posted 3 months ago. Jul 27, 2018 - 11:53 UTC
Investigating
We are experiencing some slowness with the Bintray. This is currently being investigated.
Posted 3 months ago. Jul 27, 2018 - 11:40 UTC
This incident affected: Website, REST API, and Downloads.